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NOTE OF WARNING THIS WAS WRITTEN TO USE DEAMWEAVER CS3 WE 
NOW HAVE DREAM WEAVER CS4 THIS MUST BE CHECKED FOR 
COMPATABILITY 
 
When you arrive in lab you should already have complete 1-7 
 

1. You should already have a partner. 
2. You should already have a topic. 
3. You should have a few images of your animal. 
4. You should know some other websites that present information about this animal. 
5. You should have two or three research papers related to your animal behavior. 
6. You should have 1-2 paragraphs written or bullet points listed about your animal 

behavior. 
7. You should know whether you want to use Tinbergen’s 4 questions, Dewsburry’s 

3 areas or some other scheme to comprehensively describe both proximate and 
ultimate explanations for your animal behavior. 

 
Now you are ready to START 

8. see the available templates 
http://academic.reed.edu/biology/courses/bio342f06/templates.html  
 if you will want more than 5 pages use template A. 

9. Download and unzip your preferred template onto the desktop. 
10. Change the folder name to your initials (e.g. scpr_site) (use_no_spaces_no_caps) 
11. Open dreamweaver select New Site from the Site menu 
12.  Name your site (use_no_spaces_no_caps)  
 do not enter a URL and  
 click Next 

13. Select  
click Next 

14. Specify the name of your website folder on the desktop by 
clicking on the folder button  and navigating to your folder.  

 click Next 
15.  For now chose None as the option for connecting to your 

remote server.   
 click  Next and  Done. 
 
 
Each time you work ok your website on campus you will need to repeat steps 11-15 
after dragging your site folder from your home server to the desktop.  Be sure to 
replace your site folder to your home server at the end of each work session. 
 

16. You now will see the contents of your folder listed in the Files panel to the right 
of the screen. (you may need to adjust the width to see it all and click the arrows 
to expand folders to see their content.) 
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The bio342.css file is where you specify text fonts and 
colors. 
 
The images folder is where you will store all images 
for your website. 
 
The index.html file will be your home page. 
 
The bio342templateA.dwt in the Templates folder 
will be used to create new pages that look similar. 

While it might seem cumbersome at first, using *.css file and a template will greatly 
increase the efficiency of updating files and help to maintain a uniform look to your 
website. 
 

17. open all 3 of these files by double clicking on the 3 icons in the Files panel tab. 
18. From the View menu select Code and Design and adjust the divider so 

that you can see most of your design and some of your code when you 
are looking at the template of index files.  (The *.css file is all code).  
Currently the *.css file (Cascading Style Sheet)  specifies some rather 
boring styles.  

 
WORKING IN THE *.css FILE 

19. All changes that you make to the .css file will be propagated to all web 
pages that are linked to this file (i.e. anything linked to your template 
page that is linked to the .css file). 

 
20. when you see the gray text  /* Don't change this */  it means to NOT change 

the text on that line. 
 
21. To see the “properties” for each CSS style you will need to resize the tabs on the 

right to make that for CSS STYLES larger. 
 

22. To change the color of the header 
 find the text  

/*-----------------------------------*/ 
/* The header at the top of the page */ 
/*-----------------------------------*/ 
#header { 
 background-color: #666666; 
 color: #ffffff; 
 padding: 15px; 
} 

 click in this text and the Properties panel will display the 
color information for the header. 

 click on the color swatch and the color picker palette will appear. The code for the 
selected color will replace the current gray color codes. 

 You may add new properties, such as background, underline, boarder etc. 
 Go to your index.html or template and observe the effect. 
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23. Use the above strategy to alter the text color, font size, hover color etc for the left 

navigation by changing the *.css file text under the header. 
/*--------------------------------*/ 
/* The navogation bar on the left */ 
/*--------------------------------*/ 

24. Again use the same strategy to alter the text color, font size, etc for the headers 
and text that will appear in the main content of your website. 

25. You can also edit the properties of the .css file by clicking on the pencil icon 
while your cursor is in the style section you want to edit.  This will bring up a new 
dialog box with several tabs for the different types of properties you can edit. 

26. Additional headers can be added here also.  
 Copy an existing one from # to }  
 paste it below.   
 Then change the name(s) (the dual names are not necessary). 
27. Enough for now, but this is where additions should be made if they are to be 

propegated throughout the website. For example: 
 Border colors can be set. 
 Link colors can be changed 
 List properties can be created. 

 
WORKING WTIH THE TEMPLATE 

28. All changes that you make in the template file (outside of the editable areas) will 
automatically be propagated to all web pages built from of this template. 

29. Update the year to 2011 rather than 2006 by typing in the Design Window. 
 Notice that as you type in the design window the code above is automatically 

updated. 
30. Add an informative title rather than "Title Here". 
 This should be the Title of your entire website.  This text will appear on every 

page in your website. 
31. Add the authors names to the header. 
 After the Year, type return and then your name 
 Notice the font 
 Notice the code. 
<h2>Biology 342 Fall 07</h2> 
<p>Author: Suzy Renn</p></td> 
 Working in the code, use cut and paste to change the code so that the author name 

is inside the h2 tag. 
<h2>Biology 342 Fall 07 <p>Author: Suzy Renn</p></h2> 
 When changes are made in the code view the CSS style panel 

will appear and you must click the Refresh button at the bottom 
of the screen 

 Notice how this changes the font 
 To use single line spacing rather than double spacing (paragraph break) while 

working in the Design Window, Go back and Delete the author name and this 
time hold down the shift key when you hit return before typing the author name. 

 Notice the difference in the code in the Code Window (<br> instead of <p>) 
<h2>Biology 342 Fall 07<br> 
Author: Suzy Renn</h2> 
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32. Change the link to "Adaptation" to be "Adaptive Value" so as to avoid confusion. 
 Again, this can be done in either the Code View or the Design view. 
 
33. The required five links have been made for you.  The pages you create (below) 

must have these names or these links will not work. To add more than the 
required 5 pages this is where you can create additional link(s) by copying one 
line and pastinig it below and changing both the text to appear on the link and the 
name of the .html file that will be created for the corresponding page.  

      <li><a href="../index.html">Home</a></li> 
      <li><a href="../phylogeny.html">Phylogeny</a></li> 
      <li><a href="../ontogeny.html">Ontogeny</a></li> 
      <li><a href="../mechanism.html">Mechanism</a></li> 
      <li><a href="../adaptation.html">Adaptative value</a></li> 
      <li><a href="../references.html">References</a></li> 
34. It is possible to use multiple templates in a single website (not today). 
35. It is possible to add additional content boxes (not today). 

 
CREATING NEW PAGES 

36. Create 5 new pages (index.html will be the home page for your site). These must 
have the file name (s) that are specified on the template page.  

37. From the File menu, select New  
38. Select Page from Template 
39. Highlight your own site (here SCPRsite). 
40. Select the correct template (bio342templateA). 
41. Check the box to automatically update each page 

when the template is changed. 
 
 
 

42. Click the Create button. 
43. The first thing to do is to save the untitled document that has appeared. 
44. From the File menu select Save As  
45. Check that it will be saved in your site root. 
46. Name the file to match the file names specified for the links in the template file.  

Capitalization is important. 
47. It is good practice to use no spaces, no capital letters, and short file names. 
48. Notice that on these new pages, you can only change the text that is in the content 

box.  It is a good idea to close your template file when you are not working on it 
so that you do not accidentally change it. 
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ADDING HEAD TAG INFORMATION 
Head Tags, such as Key Words and Description are used by search engines and can help 
users to find your site efficiently. Head Tags added to the template page will propegate 
through all linked pages.  Head Tags added to individual web pages will be specific to those 
web pages.  Adding Head Tags to individual web pages will add to the Head Tags, not 
replace the Head Tags specified by the template. 

49. The web page title will be displayed as the primary line returned by a search 
engine such as Google, therefore an informative title will be useful.  The current 
title that is brought in with the template is not informative. 

 At the top of your page delete the text Bio 342 Fall 06 and enter a useful title 
related to the topic of each webpage. 

 
 
 
 
 
 

 Notice that your new text appears in the code near the top of your page 
   <title>phylogeny of stickleback mating behavior</title> 
 
50. The web page Keywords are searched by search engines though they are not 

displayed in the web browser.  
 Good Keywords include, common 

misspellings of your name or the species 
name, related topics, names of prominent 
researchers in the field, taxonomic 
descriptions of your organism etc.  

 From the Insert menu select HTM/Head 
Tags/Keywords 

 Enter appropriate keywords and click 
OK. 

 You can always add more keywords to 
each website either using the above 
instructions or by typing directly in the 
code with in the parentheses at  
<meta name="keywords" content="susie wren susy susan ">   

  
51. The web page Description is also used by search engines and may be informative 

to potential readers.  This is often the text that shows up underneath the web page 
Title in the Google search results. 

 Good Descriptions include short descriptive phrases.  
 From the Insert menu select HTM/Head Tags/Description 
 Enter appropriate text and click OK. 
 Notice that the description text appears within a meta tag in similar format to the 

keywords above. 
 <meta name="description" content="description of suzy's webpage"> 
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ADDING TEXT CONTENT TO INDIVIDUAL PAGES 

1. To add text to individual web pages type the directly in the Design View. 
 Text can also be added using copy/paste function from word, text pad, .pdf files, 

other websites etc, but some formatting may be lost and some retained. 
 It is advisable to use the Edit menu and Paste Special and choose Text Only and 

then format your text within Dreamweaver.   
 Text copied from other files in Dreamweaver should retain the associated 

formatting. 
 
2. The text style can be specified to be any of the style class described in the .css file 

for that editable section. 
 The Header 1-6 styles can be accessed from the Format button  
 Any Custom style (you’ve probably not made one yet) can be accessed from the 

Class button 

  
3. To specify a new style right click (ctrl) in the CSS Styles Panel & select New. 
4. The New CSS Rule window will appear 

 
 
5. Leave the Selector Type set to Class. 
6. Enter a name for Selector Name. 
7. Here funstyle is the class that will appear as a tag in the code. 
8. If the style should be applicable to all pages on your website, set Choose where 

your rule will be defined to be the .css file related to this website.  
9. Click OK to bring up the Definitions window in which you can specify the new 

rules such as colors, boarders, backgrounds, font etc.  
 Go look at your .css file and see how the new class is 

coded. 
 The new style will now appear on the pop-up class 

menu. 
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ADDING IMAGES TO INDIVIDUAL PAGES 
1. In Photoshop reduce the resolution to 72 dpi (web browsers do not have higher 

resolution so there is no reason to use larger files that will slow browsers). 
2. Save all images as .jpg files in your images folder in your site file with short 

informative names that contain no spaces and no capital letters. (use .gif files for 
line are or simple 2 color images). They appear in the dreamweaver Site menu. 

3. To place the image on the individual website: 
 Either drag and drop them into place from the File panel in the Site menu. 
OR 
 From the Insert menu choose Image and navigate to the image file.  If it is not 

already in your images files within your site file you will be prompted to save a 
copy of it in your site folder  

a. Note images will automatically go into the root folder not the images 
folder unless you specify so, but from the site manager panel within 
Dreamweaver you can drag the image into the images files and the 
code will automatically update.  If you move website images and other 
files in Finder outside of Dreamweaver the code will not update and 
your links will be broken.  

4. You will be prompted to add alternate text.   
 This text would appear on a browser that does not show images. It is useful to 

give a short description of the image. 
5. While it is possible to resize image sizes in Dreamweaver using the 

dimension settings in the image formatting palette if the image is 
selected, it is best to do this in Photoshop before inserting the image. 

6. In the image formatting palette, if the second dimension is left blank, the 
original ratio is maintained. 

7. To position the image and wrap the text use the Align button in the Properties tab 
at the bottom of the screen. Try different options.  

8. Using these same steps, images can be placed in non-editable regions 
of the template file to be propagated to all linked web pages.  

 
INSTERTING NAMED ANCHORS  
Named Anchors specify a particular place in a webdocument.  These are useful for 
navigating within or between documents when you want to direct the reader to a specific 
point in a large document.  

1. In the Document window’s Design view, place the insertion point where you want 
the named anchor. 

2. From the Insert menu choose  Named Anchor. 
3. The Anchor Name box will appear. 
 Type a name for the anchor,  
 and click OK.  
 (The anchor name CANNOT contain spaces). 
4. The anchor marker appears at the insertion point. 
5. Notice that for commonly inserted objects there is a shortcut tab on the right of 

the screen that allows you to do this without going through the menu. 
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INSERTING HYPERLINKS 
Hyperlinks let you create a text link to a particular location in the current document 
(using Named Anchors as above) or to link to another web document either within your 
website or outside. 

1. Place the cursor in the document where you want the link to appear (or highlight 
the text to serve as the link). 

2. from the  Insert menu choose Hyperlink. 
3. The Hyperlink box will appear 
4. Enter the text of the link after Link  
 (or if you highlighted text it will appear in that space) 
5. Enter the name of the file to link to  
 (or click the folder icon to browse to the file). 
6. In the Target pop‑up menu, select the window in which 

the file should open or type its name. 
 _blank : new browser window. (good for linking to outside sites without loosing 

your reader) 
 _self  : loads in same browser (best if you are moving within 

your own site) 
7. Click OK. 

 
To link to a Named Anchor 

1. In the Document window’s Design view, select text or an image to create a link 
from. 

2. Click on the Hyperlink button (looks like a chain link) 
3. In the Link box of the Property inspector, type a number sign (#) and the name of 

the anchor. For example: 
 To link to an anchor named “top” in the current document, type #top.  
 To link to an anchor named “top” in a different document in the same folder, type 

filename.html#top .  
Anchors are useful in long webpages with lists. They are often used for alphabetical 
lists, or to return to the top of a page or to the citations at the end of a page. 
 

WORKING WITH TABLES 
Tables are a powerful tool for presenting tabular data and for laying out text and graphics 
on an HTML page. A table consists of one or more rows; each row consists of one or 
more cells. Although columns aren’t usually explicitly specified in HTML code, 
Dreamweaver enables you to manipulate columns as well as rows and cells. 
 
Cells within a table can be merged or split to offer flexibility in layout. 
 
Tables are often useful when you have many images to present and text that is explicitly 
associated with specific images. Talk to your TAs or Suzy for help with tables if you 
think this would be useful for your website. 
 
 

 


