
INTRODUCTORY EXCEL TUTORIAL 
This handout was designed for the Introductory Excel workshop, held early in each 
semester at the DoJo. For a schedule of upcoming workshops, check the Academic 
Support website (here), or sign up for workshop alerts via this link. If you’d like to request 
a workshop for you and your friends, or would like one-on-one help with Excel, please 
contact Emily at esuvada@reed.edu, or book a coaching session at 
http://esuvada.youcanbook.me 

If you want to learn more on your own, a simple google search will bring you to many 
sites with step-by-step guides to almost any calculation. Excel has been around for 
many years and has an enormous user base. Just remember to include the version and 
platform information (i.e. Excel 2011 for Mac, Excel 2016 for Windows, etc). 

TOPIC 1 - ENTERING AND FORMATTING DATA INTO EXCEL.  

This handout was written for Excel 2016 for Mac OS X. Other versions of Excel have 
similar features, but the buttons and menus may be presented differently.  

Here are a few facts that I would like to enter into an Excel spreadsheet:  

• The 2010 population of Oregon was about 3.9 million. 
• The 2010 population of California was about 38 million. 
• The 2010 population of Washington was about 6.9 million. 
• The land area of Oregon is about 96,000 square miles. 
• The land area of California is about 156,000 square miles. 
• The land area of Washington is about 66,000 square miles. 
• In 2010, approximately 22.1% of Oregonians were under 18 years old. 
• In 2010, approximately 24.3% of Californians were under 18 years old. 
• In 2010, approximately 23.0% of Washingtonians were under 18 years old. 

How can I most effectively organize this information in Excel?  

First, identify the variables, and the cases. If you’re not sure which is which, consider the 
definition below: 

Variables are attributes that can be measured. 

Cases are the objects that have these attributes.  

In the example above, the variables measured are “population”, “land area” and 
“percentage of population under 18”. The cases studied are “Oregon”, “California” 
and “Washington”.  



Each of these 9 data points will occupy a single cell in the spreadsheet. The variables 
will be columns (i.e., presented vertically), while the cases will be rows (i.e., presented 
horizontally).  

SKILL: SELECTING CELLS 

You can select a cells in the following ways: 

• Select a cell by clicking anywhere within its borders  
• Select a whole row by clicking the row number on the left.  
• Select a whole column by clicking the column letter.  
• Select multiple cells in a block using one of three methods:  

o click the first cell and drag across the block 
o click the top-left cell, then hold Shift and click the bottom-right cell 
o click the top-left cell, then hold Shift and use the arrow keys to select the 

block 
• To select non-contiguous cells, hold the “command” (⌘) key as you click them. 

Once entered, the data will look as shown below: 

	

	

Now, this information isn’t easy to read. It would be better if we had a row at the top 
with the names of our variables. So, let’s insert a row and add data names. It’s also a 
good idea to include the units the measurements are in. 

SKILL: INSERT/DELETE A ROW (OR COLUMN) 

Right-click (or hold “Control” on the keyboard while clicking) on the name of a column 
(or row). Choosing “Insert” will create a new, empty column immediately to the left of 
the selected column (or above the selected row). To delete, follow the same process, 
but click “Delete”. What happens if you do the same thing while right-clicking on a 
cell? What options are there for inserting? Try them out with a data set, to see what 
happens 

With column names, our data looks better. If you need to resize a column or row, click 
on the border to drag it. You can also double-click the border to automatically resize: 



 

Okay, now our data is a little easier to take in. However, the numbers are long and hard 
to read. We want to change these number formats. 

SKILL: CHANGING NUMBER FORMATS 

Change number formats quickly by selecting the cells with numbers you want to 
change, then clicking on the format options in the “Home” tab. Quick options include 
accounting formats, percentages, and ways to change the number of decimal places.  

For more options, you can right-click on a selection of cells and go to “Format Cell”. 
Note the keyboard shortcut listed – shortcuts in Excel can save a lot of time! In this 
menu, you can change formats for text entries, times and dates, and even custom 
formats for your own data. 

Here’s some data with number formatting applied: 

 

 

TOPIC 2 – SAVING AND IMPORTING DATA  

At this point, it’s a good idea to save your spreadsheet! 

SKILL: SAVING EXCEL SPREADSHEETS	

To save this spreadsheet for later use in Excel, simply choose “Save As...” from the File 
menu. The default format is *.XLSX, which saves the spreadsheet exactly as it appears in 
Excel.  Some other programs are able to import Excel files directly, but if your goal is to 
export your data for use in another program, you should choose to save your file as a 
comma- separated variable text file (*.CSV). You can choose this option from the 
“Format:” pull-down menu in the “Save As...” dialog box. You will likely encounter a 
warning dialogue that says features of the file may be lost. 

This is because CSV files are simply text files with your data encoded in them. They will 
not save formatting, formulas, graphs, or anything else that you’ve produced within 



Excel. Before exporting data to a CSV file, it’s a good idea to first save your spreadsheet 
as a XLSX file, to ensure that you don’t lose any of your work.  

A note on formatting data for compatibility  

Each cell in Excel is assigned a data type, which determines how the data in the cell is 
dealt with “behind the scenes” and how it is displayed within Excel. Most of the time, 
the default data type is “general.” The “general” format works reasonably well for many 
uses in Excel, but can lead to some trouble when trying to export the data to another 
program. To avoid these problems, you should change the format of each cell to a 
more specific data type (e.g., number, text, date). Usually, you can do this by column, 
since a single column often contains only a single type of data.  

SKILL: IMPORTING DATA FROM CSV 

To import data from another source, CSV is again a helpful format. You can either open 
a CSV file using File>Open, or if you would like to import the data into an existing Excel 
workbook, click where you would like the data to begin, and then choose Data- >Get 
External Data->Import Text File. Either of these Methods will launch Excel’s Text Import 
Wizard. 

TOPIC 3 - USING FORMULAS  

All formulas in Excel begin with an equals sign ‘=’. Once you press your “enter” key, 
Excel will perform a computation and display the result of that computation in the cell. 
When you select a cell containing a formula, the original formula (and not just its result) 
becomes visible in the formula bar, which appears just above the spreadsheet (and 
below all of the other toolbars).  

Some formulas simply perform calculations on some given numbers. For example, 
entering “=2+3” in a cell will cause “5” to appear in that cell. More powerful formulas 
refer to values in other cells of the spreadsheet. Entering “=B3+B4” will result in the sum 
of the numbers in cells B3 and B4.  

SKILL: USE A SIMPLE FORMULA 

In our test spreadsheet, let’s calculate the total land area in all three states. First, click 
on cell C6 and put in a title so we later know what we’ve calculated. Then, in C7, enter 
the following formula: 

=C2+C3+C4 

This will give us the total land area! Now, we can also enter this formula without as much 
typing. This time, click on C8. Type the “=” sign in the formula bar, and select C2, wither 
by clicking or navigating with the arrow keys. See how it appears in the formula? Add a 
plus sign, then click on C3. Do the same for C4. Thus, we can enter formulas by 
selecting cells instead of typing their addresses in. There is a third, and even easier way 
to do this calculation, by using a function. 



SKILL: USE FUNCTIONS IN EXCEL 

A function in Excel performs a fixed operation on a given set of inputs. Functions are 
distinguished by their all-caps names. The AVERAGE function returns the arithmetic 
mean of a set of inputs. The SUM function calculates the sum. To continue our land area 
example, let’s do the following,  

1. Select C9, and type “=SUM(”   

2. Select the range of cells whose values you would like to average. You can do this 
with your mouse (using the rules in the previous section), by navigating and 
holding shift, or by using Excel’s formula syntax to enter the data range by 
keyboard. For a beginner, I recommend using your mouse first, but paying 
attention to the way that Excel represents the data range you have selected.   

Excel has many, many functions available to use. To learn about other functions, try 
exploring the Functions section of the Formulas tab, and especially the “Reference” 
button. Google search is also a good resource. Formulas to note are: 

• =LN( x )  - calculate natural logarithm of x 
• =LOG10( x )  - calculate log of x, base 10 
• =LOG(x, y) – calculate log of x, base y 
• =AVERAGE(range)  - arithmetic mean of a range 
• = SUM(range)  - sum of a range 
• = MAX(range) and MIN(range) – the maximum or mimimum value in a range 
• = COUNT(range) – calculate the number of non-blank values in a range 
• =STD(range) – standard deviation in a range 
• =MEDIAN(range) – median of range (some programs calculate medians 

differently, be careful!) 

To copy a formula used in one cell to potentially many other cells,  

1. Select the cell that contains the formula, and select “Copy” from the Edit  menu.   

2. Select the range of cells where you would like the formula copied.   

3. Choose “Paste” from the Edit menu.   

The cells referenced in the original formula may change in the copied formulas. For 
example, if the original formula references cell C3, and the formula is copied to a cell in 
a lower row, the new formula may now reference C4. This is because cell references in 
the format “C4” are relative. You can “lock” a formula to a particular cell by changing 
its address in the formula bar to the form: “$C$4”. This is called an absolute reference. 
Use the shortcut (⌘+4) to quickly change a cell’s absolute/relative address. 

TOPIC 4 – MANIPULATING DATA  

Now that you can manually enter and import data, as well as run functions and write 
equations, it’s time to consider ways to manipulate data in Excel. 



Some useful tools are listed below, but not covered extensively here. More information 
can be found online, but the best way to learn these tools is by using them yourself. 

Freeze the top row or column: Choose the Layout menu from the ribbon near the top 
of your screen. Near the far right of the Layout toolbar, select “Freeze Panes.”  

Use the Text to Columns tool: Data -> “Text to Columns”. This tool can be helpful to 
create several columns from a single column of text. For example, you could take a 
column of names presented in the format “Obama, Barack” and split it at the comma, 
resulting in a column of last names and a separate column of first names.    

Sorting data: Sort data by following steps: 

• Select the data you would like to sort.  
• Click on “Sort...” from the Data menu.  
• If your data has a header row, make sure that “My list has headers” is checked in 

the resulting dialog box. This will preserve the variable names in the top row after 
the sort.   

• Next, choose the column (variable name) that you would like to sort by, as well 
as any other preferences you have for sorting by that variable.  

• If you would like to sort by multiple criteria (e.g., sorting a list of Reed students first 
by class year, and then alphabetically by last name within each class year), click 
the ‘+’ button to add a second sorting variable.   

Filtering data: Filtering causes rows that do not meet specific criteria to be hidden. To 
filter, follow these steps: 

• Select the data you wish to filter.  
• Click the filter button from the “Sort & Filter” section of the Data tab. This causes 

a filter button to appear in the top cell of each column.  
• Clicking this button will bring up a menu box:  	

  
• Choose a filtering method (e.g., equals, greater than, contains) from the 

“Choose One” menu, and enter a value in the empty box to the right. For 
example, choosing “greater than” and entering “300,000” will hide all rows that 
do not have a value in this column that is greater than or equal to 300,000.  



To show all data (turn off filters), again choose Filter from the Data menu.  

TOPIC 4 – GRAPHING DATA  

Graphing in Excel is a broad topic that can be covered in a workshop of its own. A 
basic overview is shown below. 

Graphing is roughly a 3-step process: 	

1. Plan: Before beginning your graph in Excel, you will need to know what data range 
you want to graph and what type of graph you would like to make. If you’re working 
with a complex workbook, you may want to copy/paste the data you’ll be graphing 
into a clear area. Before asking Excel to graph something, you should be able to 
roughly sketch what the graph should look like: What information is represented on the 
horizontal and vertical axes? Should the graph be a line graph, a scatterplot, a bar 
graph, or something else?  

2. Rough Draft: Select the relevant data range. Choose Charts from the ribbon at the 
top of the screen, and then select the graph type. (Although there are a ton of options 
for graph types, you’ll probably want to choose something simple, at least for a first try.)  

3. Make it pretty: Excel is (sometimes) pretty smart about formatting the graph to at 
least approximate your vision. However, there are bound to be some changes that you 
would like to make. To do this, click on the graph to select it, and then choose Chart 
Layout from the purple section of the green ribbon at the top of the screen. You may 
want to change or format:  

• The title of the graph 
• The title of the horizontal and vertical axes  
• The legend for the graph  
• The color scheme (this is actually in the Charts screen, not Chart Layout)  

Consult with your instructor about graph formatting standards for a course. 


