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MATE PREFERENCE WITH BACKGROUND COLOR INTERFERENCE IN GUPPIES 
 
In a variety of species, females choose mates on the basis of traits such as male body size, 
ornamentation, courtship vigor or morphological symmetry. In general, the two sexes have 
very different reproductive strategies, females being more discriminating in their choice of 
mates than males are. For example, Bateman (1948) observed that male fruit flies try to mate 
with almost any female, whereas females tend to interact with a number of males before they 
allow one to mate. These sex differences in mating tactics are probably related to sex 
differences in the costs of making poor mating choices. Compared to males, females typically 
incur greater reproductive costs (egg production, gestation, incubation, lactation), and as a 
result, females run the risk of paying a greater cost for making poor mate choices (Trivers 
1972). Consequently, females often choose carefully among potential mates, and males 
display vigorously to attract females. (For further explanation see chapter 8 in Essential 
Animal Behavior, or Chapter 10 in Alcock).   
 
Guppies (Poecilia reticulata) have been used extensively to gain an understanding of sexual 
selection and the evolution of mating systems. Several competing and complementary 
theories can be used to explain the evolution of female choice. Careful empirical studies are 
important in order to determine which theories apply to which species. 
 
The purpose of the current study is to determine the effect of the immediate environment on 
mate choice by female guppies.  
 
It has been shown that females prefer "showy" males, those with a larger area of orange 
color (Figure 1A).  The orange color on guppies is similar to, and is in part due to, the 
coloration of a preferred food source, the fruit from the cabrehash tree in Trinidad (Figure 1 
B) (Rodd et al., 2002). This color may signal to females that the male is healthy due to 
efficient feeding capabilities. According to the “Good genes hypothesis” (Andersson, 1994) 
females benefit indirectly by choosing males based upon "honest signals" that indicate genes 
for good health.  

 
Is the orange coloration an honest signal of healthy genes in male guppies?  
 
An alternate theory suggests that the male's orange coloration may be a “sensory trap”. 
According to this theory the males orange color exploits the female's preference for orange 
that initially evolved for detecting the nutrient rich cabrehash fruits (Christy, 1995). Signals 
that contrast the environment are more readily detected. Therefore, once established, 
preference for a color may evolve further due to contrast with the environment.  

Figure 1 Orange coloration of Poecilia reticulata  (A) is 
similar to orange color of cabrehash fruits found locally 
in Trinidad.  
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By determining whether a female's preference varies with the degree of contrast 
between signal and environment, we can address the relative contribution of 
these two hypotheses. We will measure the strength of a female's preference for 
showy over drab males on orange (low contrast) and blue (high contrast) 
backgrounds. We will also measure the coloration of the males in the experiment 
to determine which body color, blue or orange, affects preference in different 
environments. 
 
Before you begin lab, consider what experimental results will support the 
"Good genes"  theory over the "Sensory Trap enhanced by Contrast" 
theory. 
 
METHODS 
Animals: 
The guppies used for this lab are a captive reared population obtained from 
NatureBoysPets suppliers. They have been maintained at Reed since 2008. 
 
Materials for each photostation (3/lab): 
  1 digital camera  (batteries, CF card, download cable)  
  1 tripod 
  paper towels 
  ruler 
  pencils 
  
Materials for each pair of students: 
Animals:  4 female guppies (housed 4 weeks in all female tanks) 
  8 male guppies (housed 4 weeks in all male tanks) 
    ( 4 showy and 4 drab ) 
  (ideally all animals would be inexperienced virgin animals) 
 
Setup:  2 five gallon aquaria  
  4 clear plexiglass dividers   
  4 black plastic dividers   
  4 finger bowls (for holding males) 
  1 orange, 1 blue, 1 white and 1 black tank shroud 
    (10 inches X tank circumference) 
  1 small dip net 
  ruler 
  sharpie 
  timer 
 
Note: This lab could possibly be scored more accurately with a computerized 
event recorder such as JWatcher. However, the time required to create the *.gdf, 
*.fmf and *.faf would preclude an introduction to ImageJ, the image analysis 
software.  



Bio342_Animal_Behavior_2008   
 

 
 3 of 3  

 
Setup: 
A 5 gallon aquarium will be divided into 3 
sections as shown in Figure 2. Each end 
section, 6 cm, will be used for one male 
while the center section will contain the 
female. The center section is divided into 
three equal sections. The water depth will be 
only 6 centimeters and the background color 
shroud will extend 4 centimeters above the 
water.  Use tape on the table under the tank 
to identify the center sections because the 
experiment will be viewed from above. Make 
a record of your setup including any 
discrepancies that might be important. 
 
 
 
 
Experimental Trial: 
Each pair of students will test 2 females in each of 4 background color conditions 
(orange, blue, white, black). The female will be placed in the center compartment 
while 1 showy male will be placed on one end compartment and one dull male 
will be placed in the other end compartment. The fish should be allowed to 
acclimate to the testing apparatus for 10 minutes. Begin the trial by lifting the two 
removable black dividers. The timer should be set to beep every 10 seconds for 
5 minutes. A score will be recorded on each beep (see Preference Score below). 
 
 
Instructions for setting a stopwatch to beep every 10 seconds: 
upper left button =     Reset \Select                  upper right button =    Start\Stop\Set 
          Lower right button = Chrono/Timer   
Chrono/Timer switch from Chrono to Timer 
Select 3 times 
Set 1 time 
Select 3 times 
 
press-Start 
Stopwatch will beep every 10 seconds and count the number of 10-second intervals. 
press-Stop 
Reset 
 
 

Figure 2: Female guppy preference setup 
in a 5 gallon glass aquarium 
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Experimental Design: 
The testing should be randomized. (Consider why this is important). Before 
you begin do the following coin flips to randomize your experimental design. 
Repeat this process for the 4 females that you will test and record your 
experimental design in your lab notebook before you begin working. 

1. Flip a coin. If it is heads, the bright male will be placed in the compartment 
on the right. 

2. Flip the coin again. If it is heads, the black or white background will be 
used before the blue and orange backgrounds. 

3. Flip the coin again. If it is heads, the white will be used before black. 
4. Flip the coin again. If it is heads, the orange will be used before blue. 
5. All 4 backgrounds will be tested for each set of 1 female and 2 males. 

 
Preference Score: 
Female preference can be scored in many ways. Preference could be considered 
to be a categorical result; either the female showed a preference or she did not. 
Some studies use >60% time spent as the threshold for "preference". Consider 
what statistical test you would use if you collected categorical for 
preference in the 4 different background color environments. 
 
Anne Houde (Lakeforest College) has developed a scoring 
system for preference by female guppies in the experiment set 
up described above (reference).  This scoring system employs 
timed recording. Every 10 seconds both males will receive a 
score according to the female's behavior using the chart below. 
Only one male can receive a positive score and the other is 
given a 0 (or both males can be given a 0). At the end of 5 
minutes a total score will be calculated for the showy male and a 
total score will be calculated for the drab male. The preference 
score is equal to the total showy male's score minus the total 
drab male's score. You will want to create a data record table 
in your lab notebook similar to the example in Figure 3. At 
the end of your experiment the preference scores will be 
recorded on the computer but the raw data should be in your 
notebook. 
 
Table 1. Scoring for Female guppies behavior  
 
 SCORE Female Behavior    
 0  - in section 2; not paying attention to either male 
 1  - in section 2; orientated towards one side 
 1   - in section 1 or 3; not paying attention to male 
 2  - in section 1 or 3; oriented towards the male 

3 - in section 1 or 3; closely following male  
 (within 1 body length of the plexi-glass)  

Male coloration photography: 

Female 

ID

Color 

bkgd

left right

male 

(Drab/

Showy)

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

total

preference = Showy Total - Drab Total

Figure 3. Possible layout 
for data collection during 
female preference test. 
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Each photograph must include a metric ruler as well as a piece of paper 
indicating the identity of each fish according to date_station(A-
K)_trial(1/2/3/4)_Color(S/D) (e.g. 20081014_B_3_S ). 
 
Check that the camera is set up correctly before taking the fish out of the water. 

• The camera should be mounted on a tri-pod, ~ 
4 inches above the photography surface. 

• The camera should be set to: 
• Macro (flower symbol)S  
• no flash 
• saving images in high quality (HQ)  
• saved to the Flash Card (CF).   

 
1. Place the fish, the ruler, and the label on 

a damp paper towel under the camera. 
2. Take a picture of the right side of the fish.  
3. View the image on the camera screen to be sure the focus is crisp 

and the full fish is in view. 
4. When all fish from all stations on that lab bench have been 

photographed, the images will be transferred to the courses server.  
 
Image Analysis: 
File Transfer: 

1. Connect to the courses server. 
2. Find your images in the folder. 

2008_labs/week6_guppy_wed(thurs)/raw_images. 
3. Drag your 8 images to your desktop. 
4. Rename your images according to the label in the photograph 

(date_station_trial_Color (e.g. 20081014_B_3_S ) ).  If you took more than 
one photo decide which one is best for each fish, rename that one and 
continue with that one.   

 
Measuring in ImageJ: 
This is free image analysis software developed by NIH.  Several 
Plugins are available which allow very sophisticated image 
analysis.  It can be downloaded for MAC or PC from 
http://rsb.info.nih.gov/ij/  

1. Open ImageJ by clicking on the microscope icon in the 
dock.  

2. Select Analyze > Set Measurements.... 
3. A pop-up window will open showing all measurement 

options. 
4. Check the box by Area 
5. Click OK 
6. Open you first image 
7. The scale must be set for each image using the rultr 

s 
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included in the image. 
8. Select the straight line tool from the toolbar. 

 
9. To calibrate this line tool with the ruler in the photo, draw a line across an 

object of known length by clicking on one end and dragging across it. 
10. Select Analyze > Set Scale from the drop-down menu. 
11. In the popup window, enter the length of the calibration object in Known 

Distance field and the appropriate units in the Unit of Length field.  
Ignore Distance in Pixels and Pixel Aspect Ratio.  Click OK. 

 
You must Set Scale every time you open a new file! but once you have set 
the scale it is ok to use the magnify tool to change the size of the image on 
the screen for a particular image. 
 
Measurements:  

12. Select the Freehand selections tool.  
13. Trace the outline of the fish body, 

excluding the tail.  
14. You may start over if you are not 

happy with the outline you have drawn.   
15. Select Analyze > Measure from the top menu.  
16. Notice, ImageJ calculates the area inside the outline of your fish shape.  

This value is recorded in the Results window.  
17. If you make a mistake you may delete an entry by selecting the erroneous 

measurement in the Results window and then selecting Edit > Clear.     
18. Use the mouse to outline the most anterior orange patch 
19. Select Analyze > Measure. 
20. Select Analyze > Label. Notice that the corresponding number will appear 

on your image. 
21. Each time you measure an object it must be labeled. 
22. Measure and label each orange patch working from the head to the base 

of the tail. 
23. In your lab notebook record how many orange patches were measured for 

this fish. 
24. Measure and label each blue patch working from the head to the base of 

the tail. 
25. In your lab notebook record how many blue patches were measured for 

this fish. 
26. When you have measured all orange and blue color patches for this fish 

save the results file. Name it according to date_station_trial_Color (e.g. 
20081014_B_3_S.txt ).  

27. Save your labeled image with a new name as a .jpg file (e.g. 
20081014_B_3_S_label.jpg).   

28. Open the next image file and repeat steps 2 - 27.   
29. The scale should be roughly the same if the camera mount was not 



Bio342_Animal_Behavior_2008   
 

 
 7 of 7  

changed, but it will be more accurate to reset the scale for each image.  
30. The name of the image file is recorded in the Results file so one Results 

file can be used for all 4 images. It is a good idea to save the Results file 
after each image to protect your data from computer crashes. 

31. By opening your .txt results file in Excel (or by hand), calculate the total 
orange area and the total blue area for each fish.   

32. Divide those values by total body area to obtain the % orange  and % 
blue.  

 
These measurements made in ImageJ are your raw data. Because it is very easy 
to loose track of computer files (i.e. hard drives crash and files become 
corrupted) it is a good idea to back this data up either by printing a hard copy of 
the results file at the end of the day, recording the measurements directly into 
your lab notebook, or burning the data to a second hard drive or other data 
storage medium. You lab notebook should provide a clear record of where this 
raw data can be found.  Often times, a data set collected on a computer is too 
large to consider printing a hard copy.  In these cases the data back up becomes 
very important! 
 
Data Entry: 

1. Drag the file guppy_data_template to your 
desktop from 
Courses/Biology/Bio342/Labs/guppy. 

2. Rename this file guppy_data_date_initials. 
3. Open this file in JMP and enter your data in the 

appropriate columns.  
4. Save your data file. 
5. Drag a copy of your data file back to Couses/Biology/Bio342/Labs/guppy 

so that the class dataset can be combined. 
6. By entering only "Preference Score" we have omitted some 

information. This data processing step will simplify our analysis, but 
it may cause us to miss some important behavior. Consider why you 
might want to analyze the raw data using the total score for drab and 
showy males. 
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Data Analysis: (with JMP) 
Because each female was measured 4 times, we 
have a repeated measures design. We want test the 
null hypothesis that background color did not affect 
the female's preference. In JMP, to 
form a multivariate model, choose 
Fit Model from the Analyze menu.  
In the Fit model window, assign all 
4 preference scores as multiple 
Y’s in the dialog. Then select 
Manova from the fitting personality 
menu, as shown below, and click 
Run Model. 
 
The multivariate fitting platform fits the responses to the 
effects using least squares. You must still specify a 
response design by choosing Repeated Measures from 
the Choose Response popup menu. Also select the radio 
button to "Test Each Column Separately Also". A popup 
window will appear in which you can enter a name for the 
term to represent going across y-variables (e.g. 
Background_Color).  
 
We are interested in the Within Subjects test for 
Color_Background and the Prob>F provides the p-value 
that we can use to reject the null hypothesis. A p-value 
less than 0.05 supports the Environment Contrast 
Hypothesis. Each of the three other color backgrounds will 
be compared to Orange 
(because it was the first in 
the list) so we can determine 
whether there is a statistically 
significant difference 
between orange (low 
contrast) and the other 
conditions. How would you 
test whether the Blue and 
Black backgrounds had 
different effects on the 
female's preference score?  
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During this lab we collected a lot of phenotypic data from the males, such 
as total body size, % orange, and % blue. These factors could affect 
female preference in ways more subtle than the gross categorization of 
"Showy" and "Drab". Does the relative amount of orange in the two males 
affect the strength of female choice? Does the relative ratio of orange to 
blue on the showy male correlate with female choice? Does that 
correlation change on the different backgrounds? For your own records 
(which we will discuss in lab next week), create a graph that depicts 
one potentially interesting relationship, explain why (from a 
behavioral or ecological perspective) this is an "interesting" 
relationship. Then apply the appropriate statistical tests to address a 
hypothesis related to your explanation. 
 
CONCLUSIONS: 
There is no write up due for this lab. However, in addition to a clear record of 
what you did in lab today, your lab notebook should include:  

 A simple concluding statement that evaluates your results in light of the 
alternate hypotheses that were proposed to explain the evolution of 
female preference for orange color in male guppies.  

 
 There should be evidence in your lab notebook of statistical tests that 

were run, and the p-values obtained, which led you to this conclusion. 
 
 Your additional hypothesis, as well as the graphs, and statistical tests 

associated with that hypothesis. 
 
 A simple concluding statement that evaluates your results in light of this 

additional hypothesis. 
 

Aspects of this experiment have been abbreviated in order to fit within the 4 hour 
lab period and adjustments have been made to the protocol in order to allow 18 
students to simultaneously work efficiently. Consider how you would run the 
experiment differently if it were your own independent research. 

 Record your suggestions for changes to this experiment if it was your goal 
to collect data for publication. 

  
 Record any ideas that you have that would increase efficiency or improve 

this experiment in a lab course setting.  
 
 
Acknowledgements: 
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Independent project ideas: 
 
1) Fluctuating asymmetry and fluctuating environments 
It has been hypothesized that mate choice should favor individuals that display high symmetry 
because small random deviations from bilateral symmetry result from developmental "noise" in 
the morphological traits of individuals (Lens et al., 2002). This type of random developmental 
asymmetry is known as "Fluctuating Asymmetry" (FA).  According to these hypotheses, FA is an 
indicator of reduced genetic quality, or lack of buffering from environmental perturbations during 
development. However, this theory remains controversial and few robust empirical tests have 
been conducted. 
 
Despite current research that has shown behavioral lateralization for a great number of species in 
different contexts, many studies focus on the benefits of symmetry. Therefore, behavioral ecology 
has largely ignored the potential for compensatory or exploitative behaviors that capitalize upon 
the subtle asymmetries resulting from developmental instability.  
 
A recent study (Gross et al., 2007) has been the first to demonstrate behavioral responses to 
subtle fluctuating asymmetry. Gross et al (2007) reasoned that in organisms where symmetry is 
not a trait targeted by females, one might anticipate that males would attempt to take advantage 
of their own fluctuating asymmetry and "put their best side forward".  They used the guppy as 
their model organism and demonstrated that male guppies with more symmetric body color 
display both sides equally to the female during courtship, while those with high asymmetry in 
body color preferentially display their most colorful side.  
 
If contrast with background color affects female preference and a male has asymmetric 
coloration, his "best-side" might be different in two different environments. One could test to see if 
the male will display different lateralization in different environments. 
 
Consider how the male would know which side has higher contrast and would therefore be 
preferred?  
 
2) Environmental Contrast, female preference and speciation. 
There are several populations of guppies that show little genetic differentiation, and no evidence 
for post-zygotic isolation, yet the male sexually selected traits and behaviors are substantially 
different between populations (Alexander and Breden, 2004) . These characteristics present an 
opportunity to test theories concerning the role of sexual selection and mate choice behavior in 
driving speciation. 
 
It was previously thought that the group of guppies called Endler’s livebearer (“Poecilia wingei”) 
and the common guppy (Poecilia reticulata) were distinct species, however breeding experiments 
and genetic analyses have shown that the two groups are not only genetically compatible but do 
not differ according to neutral genetic markers. In the wild however, the two groups are 
essentially reproductively isolated due to mate choice. Since reproductive isolation is one of the 
harbingers of speciation, these two populations provide an exciting opportunity to observe the 
role of behavior in shaping evolution.  
 
Does the environment play an important role in the ability of these animals to perform con-specific 
mate choice? One could ask if contrast with background color affects a females ability to select 
her own species as the preferred mate.  
 
3) Environmental Contrast and mate choice copying. 
There have been several studies that demonstrate mate choice copying among female guppies. 
Younger females tend to copy older females. One could ask if this copying behavior is affected by 
the contrast with the environment. 
 


